Use mysqli or PDO hatası

Forumdan bir arkadaşımız hata hakkında soru sormuş. Bazen vBulletin kurulum esnasında böyle bir hata ile karşılaşabiliriz. Bu tür hatalar server kaynaklı olmakla birlikte çeşitli basit çözümleri de vardır. Ben bugün vBulletin için çözümünü sizlerle paylaşacağım. Ancak önce hatanın tamamını yazalım.

Hata:

mysql_connect(): The mysql extension is deprecated and will be removed in the future: use mysqli or PDO instead /home/xxx/public_html/vb/includes/class_core.php on line xxx

Çözüm için config.php dosyanızda yer alan:

$config['Database']['dbtype'] = 'mysql';

Aşağıdaki şekliyle değiştirin:

$config['Database']['dbtype'] = 'mysqli';

Sorununuz çözülmediyse forum sayfamızdan yazabilirsiniz.

Okumanızı öneriyoruz »   Rek.mobi (bu site bilgisayarınıza zarar verebilir)